Forum Title: Acting up gears
Ok, so I have one for you. 2 Dodge RAM forums stay silent on this. 2005 Dodge RAM, 4x4, auto. 166K miles. 4.7L V8 Driven few days a week, commute. Very light truck use, occasional hauls. Bought used. As of about a month now, after started, R - car is always parked nose in in garage - takes about 10 seconds to engage. If shifter moved back to P then back to R, it engages faster. Does not engage as in - nothing happens, then thump follows and truck starts rolling back. If gassed during this delay, engine roars, but no response from transmission. D does same, only much shorter, almost right away roll. ATF and both transmission filters were changed not so long ago. Level checked and is good. Dodge ATF. NO LEAKS. I have cardboard underneath, it's dry. Otherwise, outside of being slow and gas guzzler, everything else operates fine. Here's caveat. If started in Neutral, then shifted to either R or D, both engage right away. Did torque converter stall speed test, pegs at 2000 RPM. Can't find spec for TC, no idea if it's right or wrong. Also, after warmed up, no issues. Everything runs as it should. Let it sit for some time - it may have a little thump or kick, but nothing major. NO noises shifting gears manually. Transmission shifts better than my Lexus NX200. Very smooth. What makes me believe that it's not, actually, trannie. Any ideas?
Category: fencing Post By: RUSSELL CRUZ (Waco, TX), 02/11/2019

Home Improvement Solutions & Resources

requestaquote Get Free Quotes callnow 888-506-9527